CVE-2026-115946
Severity not reportedXS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder.
XS::libbrotli versions before 1.2.1.0 for Perl bundle a brotli library with an out-of-bounds write in the decoder. Affected versions compile a bundled brotli into static archives that dependent XS modules link against at build time, rather than using the system library. The bundled copy, 1.0.7 or 1.1.0 across the range, carries the decoder out-of-bounds write described in CVE-2026-111497. Version 1.2.1.0 updates it to brotli 1.2.1. XS::libbrotli has no Perl interface, so the decoder is reached through any dependent module that decompresses untrusted data with it. An attacker supplying a crafted brotli stream can corrupt decoder state, disclose memory, crash the process, or potentially execute arbitrary code. Upgrading the system brotli does not remediate this.
Affected products
Not reported by the source (unknown — not "none").
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/google/brotli/releases/tag/v1.2.1 9b29abf9-4ab0-4765-b253-1875cd9b441e
- https://metacpan.org/release/SYBER/XS-libbrotli-1.2.1.0/changes 9b29abf9-4ab0-4765-b253-1875cd9b441e
- https://www.cve.org/CVERecord?id=CVE-2026-111497 9b29abf9-4ab0-4765-b253-1875cd9b441e

