CVE-2026-120597
mediumA vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress.
A vulnerability was identified in Welcart e-Commerce Plugin up to 2.12.6 on WordPress. This affects the function ESCOTT_MAIN::error_page_message of the file classes/paymentESCOTT.main.class.php. Such manipulation of the argument ResponseCd leads to cross site scripting. The attack can be launched remotely. The exploit is publicly available and might be used. Upgrading to version 2.12.7 mitigates this issue. It is recommended to upgrade the affected component. The value is now escaped with esc_html() before output. The vendor was contacted early, responded in a very professional manner and quickly released a fixed version of the affected product.
CVSS:3.1/AV:N/AC:L/PR:N/UI:R/S:U/C:N/I:L/A:N Affected products
Not reported by the source (unknown — not "none").
Weakness classification (CWE)
Source: NVD / CISA. “NVD-CWE-Other” and “NVD-CWE-noinfo” mean NVD could not assign a specific weakness.
Mitigation & advisories
No vendor advisory or patch reference tagged by NVD. Check the references below.
References
- https://github.com/bevennyamande/welcart-poc cna@vuldb.com
- https://vuldb.com/cve/CVE-2026-120597 cna@vuldb.com
- https://vuldb.com/submit/1039186 cna@vuldb.com
- https://vuldb.com/vuln/429933 cna@vuldb.com
- https://vuldb.com/vuln/429933/cti cna@vuldb.com
- https://wordpress.org/plugins/usc-e-shop/ cna@vuldb.com

